Skip to content

dhcp-server crashes if no pool is set #1121

Description

@mattiaswal

Current Behavior

admin@infix-ad-00-00:/> configure 
admin@infix-ad-00-00:/config/> set dhcp-server 
 enabled  option  subnet
admin@infix-ad-00-00:/config/> set dhcp-server 
 enabled  option  subnet
admin@infix-ad-00-00:/config/> set dhcp-server subnet 10.0.4.0/24
admin@infix-ad-00-00:/config/> leave 
Mar 10 02:52:05 infix-ad-00-00 dnsmasq[6685]: only one tag allowed at line 6 of /etc/dnsmasq.d//net-10-0-4.conf
Mar 10 02:52:05 infix-ad-00-00 dnsmasq[6685]: FAILED to start up
admin@infix-ad-00-00:/> Mar 10 02:52:05 infix-ad-00-00 dnsmasq[6689]: only one tag allowed at line 6 of /etc/dnsmasq.d//net-10-0-4.conf
Mar 10 02:52:05 infix-ad-00-00 dnsmasq[6689]: FAILED to start up
Mar 10 02:52:07 infix-ad-00-00 dnsmasq[6690]: only one tag allowed at line 6 of /etc/dnsmasq.d//net-10-0-4.conf
Mar 10 02:52:07 infix-ad-00-00 dnsmasq[6690]: FAILED to start up
Mar 10 02:52:09 infix-ad-00-00 dnsmasq[6691]: only one tag allowed at line 6 of /etc/dnsmasq.d//net-10-0-4.conf
Mar 10 02:52:09 infix-ad-00-00 dnsmasq[6691]: FAILED to start up
Mar 10 02:52:11 infix-ad-00-00 dnsmasq[6692]: only one tag allowed at line 6 of /etc/dnsmasq.d//net-10-0-4.conf
Mar 10 02:52:11 infix-ad-00-00 dnsmasq[6692]: FAILED to start up
admin@infix-ad-00-00:~$ cat /etc/dnsmasq.d/net-10-0-4.conf 
# Subnet 10.0.4.0/24

# Common options for this subnet

# Subnet pool (null) - (null)
dhcp-range=set:net-10-0-4,(null),(null),3600
admin@infix-ad-00-00:~$ cli

See the 'help' command for an introduction to the system

Should be validated in YANG model

Expected Behavior

YANG does not allow me to configure incorrect

Steps To Reproduce

No response

Additional information

No response

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

Labels

bugSomething isn't working

Type

No type

Projects

Milestone

Relationships

None yet

Development

No branches or pull requests

Issue actions