When there is no newline at the end of pgpool.conf, parsing will fail and the process exits.
This was discovered with version 4.5.2 installed via apt. When done this way, the process immediately segfaults and does a core dump and provides no additional output.
I built pgpool from source with debug symbols enabled off the latest master (SHA 734771d). When running the version built from source, I got this error:
2024-08-14 17:06:48.098: main pid 30962: FATAL: syntax error in configuration file "/etc/pgpool2/pgpool.conf"
2024-08-14 17:06:48.098: main pid 30962: DETAIL: parse error at line 1006 '#' token = 8
The last line of pgpool.conf in this case was line 1006 which was: # Regexp are accepted (equivalent of line 1013 in the sample config).
I added a newline to the end of pgpool.conf; the version built from source no longer displays errors and version 4.5.2 installed via apt no longer segfaults.
When there is no newline at the end of pgpool.conf, parsing will fail and the process exits.
This was discovered with version 4.5.2 installed via apt. When done this way, the process immediately segfaults and does a core dump and provides no additional output.
I built pgpool from source with debug symbols enabled off the latest master (SHA 734771d). When running the version built from source, I got this error:
The last line of pgpool.conf in this case was line 1006 which was:
# Regexp are accepted(equivalent of line 1013 in the sample config).I added a newline to the end of pgpool.conf; the version built from source no longer displays errors and version 4.5.2 installed via apt no longer segfaults.